const regex = /(?:\$|\G(?!^))\d+\K,(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\$|\\G(?!^))\\d+\\K,(?=\\d)', 'gm')
const str = `apple with make,up things \$312,412,3.00`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);