#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\*{1,2}|_).*?)\s*\2"
Local $sString = "**Bold ***italic ***Bold***italic*"
Local $sSubst = "\1\2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)