import Foundation
let pattern = #"((\*{1,2}|_).*?)\s*\2"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"**Bold ***italic ***Bold***italic*"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)