$re = '/((\*{1,2}|_).*?)\s*\2/m';
$str = '**Bold ***italic ***Bold***italic*';
$subst = "\1\2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;