const regex = /((\*{1,2}|_).*?)\s*\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\*{1,2}|_).*?)\\s*\\2', 'gm')
const str = `**Bold ***italic ***Bold***italic*`;
const subst = `\1\2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);