#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(SMTP|IMAP):\sInvalid\spassword\sfor\suser\s(?<username>.+?)\s.*?\sAttempt\sfrom\sIP\saddress\s(?<ipaddress>.+)\."
Local $sString = "IMAP: Invalid password for user abc@xyz.bla. mailto:abc@xyz.bla. Attempt from IP address 186.xxx.xxx.xxx."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")