using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(SMTP|IMAP):\sInvalid\spassword\sfor\suser\s(?<username>.+?)\s.*?\sAttempt\sfrom\sIP\saddress\s(?<ipaddress>.+)\.";
string input = @"IMAP: Invalid password for user abc@xyz.bla. mailto:abc@xyz.bla. Attempt from IP address 186.xxx.xxx.xxx.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}