import re
regex = re.compile(r"(SMTP|IMAP):\sInvalid\spassword\sfor\suser\s(?<username>.+?)\s.*?\sAttempt\sfrom\sIP\saddress\s(?<ipaddress>.+)\.", flags=re.MULTILINE)
test_str = "IMAP: Invalid password for user abc@xyz.bla. mailto:abc@xyz.bla. Attempt from IP address 186.xxx.xxx.xxx."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")