using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^((feature|bugfix)\/[A-Z]+-\d+)|^(release\/(R2\d)(-)\d{2}.\d.\d))([a-z-]+)?";
string input = @"feature/JIRA-123
bugfix/JIRA-123-fix
release/R21-07.3.0
release/R21-07.3.0-fix";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}