import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^((feature|bugfix)\\/[A-Z]+-\\d+)|^(release\\/(R2\\d)(-)\\d{2}.\\d.\\d))([a-z-]+)?";
final String string = "feature/JIRA-123\n"
+ "bugfix/JIRA-123-fix\n\n"
+ "release/R21-07.3.0\n"
+ "release/R21-07.3.0-fix";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}