const regex = /(^((feature|bugfix)\/[A-Z]+-\d+)|^(release\/(R2\d)(-)\d{2}.\d.\d))([a-z-]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^((feature|bugfix)\\\/[A-Z]+-\\d+)|^(release\\\/(R2\\d)(-)\\d{2}.\\d.\\d))([a-z-]+)?', 'gm')
const str = `feature/JIRA-123
bugfix/JIRA-123-fix
release/R21-07.3.0
release/R21-07.3.0-fix`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}