# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/------start---------\n\K(?:(?:(?!------(?:end|start)---------).)+?\n){5,}(?=------end-----------)//gm;t' <<< "------start---------
first line
second line
third line
fourth line
------end-----------
xyx
pqr
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------
mdsc l
lkdmc
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------"