$re = '/------start---------\n\K(?:(?:(?!------(?:end|start)---------).)+?\n){5,}(?=------end-----------)/m';
$str = '------start---------
first line
second line
third line
fourth line
------end-----------
xyx
pqr
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------
mdsc l
lkdmc
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;