using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"------start---------\n\K(?:(?:(?!------(?:end|start)---------).)+?\n){5,}(?=------end-----------)";
string substitution = @"";
string input = @"------start---------
first line
second line
third line
fourth line
------end-----------
xyx
pqr
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------
mdsc l
lkdmc
------start---------
first line
second line
third line
fourth line
fith line
sixth line
------end-----------";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}