#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)------start---------\n\K(?:(?:(?!------(?:end|start)---------).)+?\n){5,}(?=------end-----------)"
Local $sString = "------start---------" & @CRLF & _
"first line" & @CRLF & _
"second line" & @CRLF & _
"third line " & @CRLF & _
"fourth line" & @CRLF & _
"------end-----------" & @CRLF & _
"xyx" & @CRLF & _
"pqr" & @CRLF & _
"------start---------" & @CRLF & _
"first line" & @CRLF & _
"second line" & @CRLF & _
"third line " & @CRLF & _
"fourth line" & @CRLF & _
"fith line" & @CRLF & _
"sixth line" & @CRLF & _
"------end-----------" & @CRLF & _
"mdsc l" & @CRLF & _
"lkdmc" & @CRLF & _
"" & @CRLF & _
"------start---------" & @CRLF & _
"first line" & @CRLF & _
"second line" & @CRLF & _
"third line " & @CRLF & _
"fourth line" & @CRLF & _
"fith line" & @CRLF & _
"sixth line" & @CRLF & _
"------end-----------"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)