#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*@\bc\b.*"
Local $sString = "@c" & @CRLF & _
"@c hello" & @CRLF & _
"hello @c" & @CRLF & _
"hello @c hello" & @CRLF & _
"@cat" & @CRLF & _
"@cat hello" & @CRLF & _
"hello @cat" & @CRLF & _
"hello @cat hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")