using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*@\bc\b.*";
string input = @"@c
@c hello
hello @c
hello @c hello
@cat
@cat hello
hello @cat
hello @cat hello";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}