package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*@\bc\b.*`)
var str = `@c
@c hello
hello @c
hello @c hello
@cat
@cat hello
hello @cat
hello @cat hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}