$re = '/.*@\bc\b.*/';
$str = '@c
@c hello
hello @c
hello @c hello
@cat
@cat hello
hello @cat
hello @cat hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);