import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(.*)\\((\\d+),(\\d+)\\): (\\w+) ([^:]+): ([^\\[]+) \\[(.*)\\]";
final String string = "/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,2): error WHITESPACE: Fix whitespace formatting. Insert '\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
+ "/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,3): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
+ "/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(16,84): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
+ "/app/src/R2.Server/Impl/R2Impl.cs(16,45): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread. [/app/src/R2.Server/R2.Server.csproj]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}