# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(.*)\((\d+),(\d+)\): (\w+) ([^:]+): ([^\[]+) \[(.*)\]"
test_str = ("/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,2): error WHITESPACE: Fix whitespace formatting. Insert '\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
"/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,3): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
"/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(16,84): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]\n"
"/app/src/R2.Server/Impl/R2Impl.cs(16,45): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread. [/app/src/R2.Server/R2.Server.csproj]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.