const regex = /^\s*(.*)\((\d+),(\d+)\): (\w+) ([^:]+): ([^\[]+) \[(.*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(.*)\\((\\d+),(\\d+)\\): (\\w+) ([^:]+): ([^\\[]+) \\[(.*)\\]', 'gm')
const str = `/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,2): error WHITESPACE: Fix whitespace formatting. Insert '\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,3): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(16,84): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with '\\n\\t\\t\\t'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/app/src/R2.Server/Impl/R2Impl.cs(16,45): warning CS1998: This async method lacks 'await' operators and will run synchronously. Consider using the 'await' operator to await non-blocking API calls, or 'await Task.Run(...)' to do CPU-bound work on a background thread. [/app/src/R2.Server/R2.Server.csproj]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}