$re = '/^\s*(.*)\((\d+),(\d+)\): (\w+) ([^:]+): ([^\[]+) \[(.*)\]/m';
$str = '/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,2): error WHITESPACE: Fix whitespace formatting. Insert \'\\t\'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(15,3): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with \'\\n\\t\\t\\t\'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/runner/_work/r2/r2/src/R2.Server/Services/R2Service.cs(16,84): error WHITESPACE: Fix whitespace formatting. Replace 4 characters with \'\\n\\t\\t\\t\'. [/runner/_work/r2/r2/src/R2.Server/R2.Server.csproj]
/app/src/R2.Server/Impl/R2Impl.cs(16,45): warning CS1998: This async method lacks \'await\' operators and will run synchronously. Consider using the \'await\' operator to await non-blocking API calls, or \'await Task.Run(...)\' to do CPU-bound work on a background thread. [/app/src/R2.Server/R2.Server.csproj]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);