# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})-(\d{2})-(\d{1,2})(.*)/0$3/gm;t' <<< "created: 2019-11-05 22:01 test
created: 2019-11-5 22:01 foo"