# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4})-(\d{2})-(\d{1,2})(.*)"
test_str = ("created: 2019-11-05 22:01 test\n"
"created: 2019-11-5 22:01 foo")
subst = "0$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.