package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})-(\d{2})-(\d{1,2})(.*)`)
var str = `created: 2019-11-05 22:01 test
created: 2019-11-5 22:01 foo`
var substitution = "0$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}