$re = '/(\d{4})-(\d{2})-(\d{1,2})(.*)/m';
$str = 'created: 2019-11-05 22:01 test
created: 2019-11-5 22:01 foo';
$subst = "0$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;