#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.)(\1*)"
Local $sString = "hoopla" & @CRLF & _
"abbCCCddBBBxx" & @CRLF & _
"" & @CRLF & _
"xyz" & @CRLF & _
"xxyz" & @CRLF & _
"xyzz" & @CRLF & _
"abbbcbbbxbbbx" & @CRLF & _
"XXBBBbbxx" & @CRLF & _
"XXBBBbbxxXXXX" & @CRLF & _
"XX2222BBBbbXX2222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")