$re = '/(.)(\1*)/m';
$str = 'hoopla
abbCCCddBBBxx
xyz
xxyz
xyzz
abbbcbbbxbbbx
XXBBBbbxx
XXBBBbbxxXXXX
XX2222BBBbbXX2222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);