using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)(\1*)";
string input = @"hoopla
abbCCCddBBBxx
xyz
xxyz
xyzz
abbbcbbbxbbbx
XXBBBbbxx
XXBBBbbxxXXXX
XX2222BBBbbXX2222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}