re = /(.)(\1*)/m
str = 'hoopla
abbCCCddBBBxx
xyz
xxyz
xyzz
abbbcbbbxbbbx
XXBBBbbxx
XXBBBbbxxXXXX
XX2222BBBbbXX2222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end