using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Example\s+(\d+):.*?(ERROR)?$";
string input = @"Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}