package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Example\s+(\d+):.*?(ERROR)?$`)
var str = `Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}