$re = '/Example\s+(\d+):.*?(ERROR)?$/m';
$str = 'Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);