const regex = /Example\s+(\d+):.*?(ERROR)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Example\\s+(\\d+):.*?(ERROR)?$', 'gm')
const str = `Example 1: bla bla bla
Example 2: bla bla ERROR
Example 3: bla bla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}