import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "create\\s+table\\s*`\\w*`\\s*\\(\\n\\s*`([\\w\\-_]*)`\\s*([\\w]*).*(auto_increment)([\\n\\s\\w()',`]*)(primary key)\\s*\\(`([\\w\\-_]*)`\\).*\\n.*engine\\s*=\\s*(InnoDB).*charset\\s*=\\s*([\\w\\-]*);";
final String string = "CREATE TABLE `column_statiskey_map` (\n"
+ " `ID` int(11) NOT NULL AUTO_INCREMENT,\n"
+ " `Platform` varchar(255) NOT NULL,\n"
+ " `ColumnName` varchar(255) NOT NULL DEFAULT '',\n"
+ " `Statiskey` varchar(255) NOT NULL DEFAULT '',\n"
+ " `Status` int(11) NOT NULL DEFAULT '0',\n"
+ " PRIMARY KEY (`ID`)\n"
+ ") ENGINE=InnoDB AUTO_INCREMENT=25 DEFAULT CHARSET=utf8;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}