import re
regex = re.compile(r"create\s+table\s*`\w*`\s*\(\n\s*`([\w\-_]*)`\s*([\w]*).*(auto_increment)([\n\s\w()',`]*)(primary key)\s*\(`([\w\-_]*)`\).*\n.*engine\s*=\s*(InnoDB).*charset\s*=\s*([\w\-]*);", flags=re.IGNORECASE | re.UNICODE)
test_str = ("CREATE TABLE `column_statiskey_map` (\n"
" `ID` int(11) NOT NULL AUTO_INCREMENT,\n"
" `Platform` varchar(255) NOT NULL,\n"
" `ColumnName` varchar(255) NOT NULL DEFAULT '',\n"
" `Statiskey` varchar(255) NOT NULL DEFAULT '',\n"
" `Status` int(11) NOT NULL DEFAULT '0',\n"
" PRIMARY KEY (`ID`)\n"
") ENGINE=InnoDB AUTO_INCREMENT=25 DEFAULT CHARSET=utf8;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")