const regex = new RegExp('create\\s+table\\s*`\\w*`\\s*\\(\\n\\s*`([\\w\\-_]*)`\\s*([\\w]*).*(auto_increment)([\\n\\s\\w()\\',`]*)(primary key)\\s*\\(`([\\w\\-_]*)`\\).*\\n.*engine\\s*=\\s*(InnoDB).*charset\\s*=\\s*([\\w\\-]*);', 'giu')
const str = `CREATE TABLE \`column_statiskey_map\` (
\`ID\` int(11) NOT NULL AUTO_INCREMENT,
\`Platform\` varchar(255) NOT NULL,
\`ColumnName\` varchar(255) NOT NULL DEFAULT '',
\`Statiskey\` varchar(255) NOT NULL DEFAULT '',
\`Status\` int(11) NOT NULL DEFAULT '0',
PRIMARY KEY (\`ID\`)
) ENGINE=InnoDB AUTO_INCREMENT=25 DEFAULT CHARSET=utf8;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}