use strict;
my $str = 'CREATE TABLE `column_statiskey_map` (
`ID` int(11) NOT NULL AUTO_INCREMENT,
`Platform` varchar(255) NOT NULL,
`ColumnName` varchar(255) NOT NULL DEFAULT \'\',
`Statiskey` varchar(255) NOT NULL DEFAULT \'\',
`Status` int(11) NOT NULL DEFAULT \'0\',
PRIMARY KEY (`ID`)
) ENGINE=InnoDB AUTO_INCREMENT=25 DEFAULT CHARSET=utf8;';
my $regex = qr/create\s+table\s*`\w*`\s*\(\n\s*`([\w\-_]*)`\s*([\w]*).*(auto_increment)([\n\s\w()',`]*)(primary key)\s*\(`([\w\-_]*)`\).*\n.*engine\s*=\s*(InnoDB).*charset\s*=\s*([\w\-]*);/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}