// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)\s(.*)\s(TITULAR|SUPLENTE)").unwrap();
let string = "YECOL Martin Sosa TITULAR
FAQ FACUNDO TORRES TITULAR
CURRY10 Luis Gonzalez TITULAR
BRAN Brandon Christian Suarez TITULAR
MAXII MAXIMILIANO EZEQUIEL ARIEL MAIDANA ORTIGOZA SUPLENTE
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}