import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]+\":\\s*\"[^\"]+\"[,\\}]\\s*(*SKIP)(*FAIL)|(?<![,:])\"(?![:,]\\s*[\"\\}])";
final String string = "json_str = '''{\"id\":\"9\",\"ctime\":\"2018-02-13\",\"content\":\"abcd: \"efg.\",\"hots\":\"103b\",\"date_sms\":\"2017-11-22\"}'''";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}