import re
regex = re.compile(r"\"[^\"]+\":\s*\"[^\"]+\"[,}]\s*(*SKIP)(*FAIL)|(?<![,:])\"(?![:,]\s*[\"}])")
test_str = "json_str = '''{\"id\":\"9\",\"ctime\":\"2018-02-13\",\"content\":\"abcd: \"efg.\",\"hots\":\"103b\",\"date_sms\":\"2017-11-22\"}'''"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")