# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(AANVRAGER:)\W*(.*?)\W*(___LOCATIE)/\1\2\3/gmx;t' <<< "[AANVRAAGNUMMER:__542-13___AANVRAGER: Dr.B.Leijnse en Dr.H.M. van Praag, ___LOCATIE:_Rotterdam___ONDERZOEKSONDERWERP: bestudering van het werkingsmechanisme van de anti-depressieve hydrazinen, in bio chemisch en psychiatrisch-psychologisch opzicht __BEDRAG:__ f 16.000] \n"