$re = '/(AANVRAGER:)\W*(.*?)\W*(___LOCATIE)/mx';
$str = '[AANVRAAGNUMMER:__542-13___AANVRAGER: Dr.B.Leijnse en Dr.H.M. van Praag, ___LOCATIE:_Rotterdam___ONDERZOEKSONDERWERP: bestudering van het werkingsmechanisme van de anti-depressieve hydrazinen, in bio chemisch en psychiatrisch-psychologisch opzicht __BEDRAG:__ f 16.000] \\n';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;