// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(AANVRAGER:)\W*(.*?)\W*(___LOCATIE)").unwrap();
let string = "[AANVRAAGNUMMER:__542-13___AANVRAGER: Dr.B.Leijnse en Dr.H.M. van Praag, ___LOCATIE:_Rotterdam___ONDERZOEKSONDERWERP: bestudering van het werkingsmechanisme van de anti-depressieve hydrazinen, in bio chemisch en psychiatrisch-psychologisch opzicht __BEDRAG:__ f 16.000] \\n";
let substitution = "\\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}