using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*result..([^\}]+\})";
string input = @"{""result"":{""balance"":9999,""created"":""22/03/2022 22:23:31"",""last_login"":1648876825,""stake_bli"":110.0,""stake_date"":1650240000,""username"":""username"",""verified"":""maybe""},""server"":""bla"",""success"":true}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}