re = /.*result..([^\}]+\})/m
str = '{"result":{"balance":9999,"created":"22/03/2022 22:23:31","last_login":1648876825,"stake_bli":110.0,"stake_date":1650240000,"username":"username","verified":"maybe"},"server":"bla","success":true}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end