use strict;
my $str = '{"result":{"balance":9999,"created":"22/03/2022 22:23:31","last_login":1648876825,"stake_bli":110.0,"stake_date":1650240000,"username":"username","verified":"maybe"},"server":"bla","success":true}';
my $regex = qr/.*result..([^\}]+\})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}