import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*result..([^\\}]+\\})";
final String string = "{\"result\":{\"balance\":9999,\"created\":\"22/03/2022 22:23:31\",\"last_login\":1648876825,\"stake_bli\":110.0,\"stake_date\":1650240000,\"username\":\"username\",\"verified\":\"maybe\"},\"server\":\"bla\",\"success\":true}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}