const regex = /0[1-9][0-9]{5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0[1-9][0-9]{5}', 'g')
const str = `0258714 0465666 1213655 568464668 225 75487 021523
56556 0236589 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}